Pentest Box更新Msf

现在Pentest Box更新Msfconsole需要ruby版本>=2.4,否则无法启动Msfconsole,之前都是替换ruby版本就可以解决, 但还是做了替换ruby版本尝试,替换ruby版本为2.4.9

image

image

按照错误提示,执行bundle install命令,会提示找不到文件

标黄处让执行gem install ed25519 -v '1.2.4' --source 'https://rubygems.org/'命令,可还是报现同样的错误,注意到了d:/pentestbox/base/ruby_devkit/路径,是调用ruby_devkit目录下的文件,可是通过搜索ld.exe,collect2.exe这两个文件是存在,那为什么还会报错了?根据这个疑问打开了ruby官网,发现ruby_devkit只支持到ruby的版本2.0到2.3

image

而现在的ruby版本已经是2.4.9了,意思就是ruby_devkit版本不能用了,得重新下新版本了,devkit没有单独的安装包,都做成集成安装包了。

现在Pextest Box ruby版本是ruby 2.4.9

image

那这里因下载的是Ruby+Devkit 2.4.9-1 (x86)

image

下载完安装,安装路径选择覆盖Pentest Box的ruby安装既可,安装完后执行bundle install命令,就可以正常使用Msfconsole

PS:不绕弯路的路子就是直接下载Ruby+Devkit安装包进行覆盖安装Pentest Box的ruby安装既可,然后进行更新。

  • 通过
  • 未通过

0 投票者

下载Ruby+Devkit 2.4.9-1的链接分享一下

https://rubyinstaller.org/downloads/ 这个???

谢谢